// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)name="(.*?)" value="(.*?)""#).unwrap();
let string = "<input type=\"hidden\" name=\"jazoest\" value=\"2703\" autocomplete=\"off\">
<input type=\"hidden\" autocomplete=\"off\" name=\"timezone\" value=\"180\" id=\"u_0_9\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}