const regex = /name="(.*?)" value="(.*?)"/isg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('name="(.*?)" value="(.*?)"', 'isg')
const str = `<input type="hidden" name="jazoest" value="2703" autocomplete="off">
<input type="hidden" autocomplete="off" name="timezone" value="180" id="u_0_9">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}