using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:alpha|gamma):\s+\d[\d.]+\s+-\s+(\d[\d.]+)";
string input = @"example one
-----------
alpha: 192.168.50.0 - 192.168.50.24
delta: 192.168.50.100 - 192.168.50.124
other fields: more stuff
....
example two
-------------
gamma: 200.0.0.0 - 200.0.0.64
lamda: 200.0.0.124 - 200.0.0.255
other fields: more stuff";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}