// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:alpha|gamma):\s+\d[\d.]+\s+-\s+(\d[\d.]+)").unwrap();
let string = "example one
-----------
alpha: 192.168.50.0 - 192.168.50.24
delta: 192.168.50.100 - 192.168.50.124
other fields: more stuff
....
example two
-------------
gamma: 200.0.0.0 - 200.0.0.64
lamda: 200.0.0.124 - 200.0.0.255
other fields: more stuff";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}