import re
regex = re.compile(r"\b(?:alpha|gamma):\s+\d[\d.]+\s+-\s+(\d[\d.]+)", flags=re.MULTILINE)
test_str = ("example one\n"
"-----------\n\n"
"alpha: 192.168.50.0 - 192.168.50.24\n"
"delta: 192.168.50.100 - 192.168.50.124\n"
"other fields: more stuff\n"
"....\n\n"
"example two\n"
"-------------\n\n"
"gamma: 200.0.0.0 - 200.0.0.64\n"
"lamda: 200.0.0.124 - 200.0.0.255\n"
"other fields: more stuff")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")