package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:alpha|gamma):\s+\d[\d.]+\s+-\s+(\d[\d.]+)`)
var str = `example one
-----------
alpha: 192.168.50.0 - 192.168.50.24
delta: 192.168.50.100 - 192.168.50.124
other fields: more stuff
....
example two
-------------
gamma: 200.0.0.0 - 200.0.0.64
lamda: 200.0.0.124 - 200.0.0.255
other fields: more stuff`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}