import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:alpha|gamma):\\s+\\d[\\d.]+\\s+-\\s+(\\d[\\d.]+)";
final String string = "example one\n"
+ "-----------\n\n"
+ "alpha: 192.168.50.0 - 192.168.50.24\n"
+ "delta: 192.168.50.100 - 192.168.50.124\n"
+ "other fields: more stuff\n"
+ "....\n\n"
+ "example two\n"
+ "-------------\n\n"
+ "gamma: 200.0.0.0 - 200.0.0.64\n"
+ "lamda: 200.0.0.124 - 200.0.0.255\n"
+ "other fields: more stuff";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}