#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[0-9]{1,6}X*$"
Local $sString = "12345" & @CRLF & _
"2753XX" & @CRLF & _
"542XXX45" & @CRLF & _
"4654abc" & @CRLF & _
"" & @CRLF & _
"^[0-9]{1,6}X{1}$" & @CRLF & _
"^[0-9]{1,6}X$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")