// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[0-9]{1,6}X*$").unwrap();
let string = "12345
2753XX
542XXX45
4654abc
^[0-9]{1,6}X{1}$
^[0-9]{1,6}X$";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}