package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[0-9]{1,6}X*$`)
var str = `12345
2753XX
542XXX45
4654abc
^[0-9]{1,6}X{1}$
^[0-9]{1,6}X$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}