$re = '/^[0-9]{1,6}X*$/mi';
$str = '12345
2753XX
542XXX45
4654abc
^[0-9]{1,6}X{1}$
^[0-9]{1,6}X$';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);