const regex = /^[0-9]{1,6}X*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]{1,6}X*$', 'gmi')
const str = `12345
2753XX
542XXX45
4654abc
^[0-9]{1,6}X{1}\$
^[0-9]{1,6}X\$`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}