# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.(?=.?$)/<span>$0<\/span>/gm;t' <<< "-1:23"