const regex = /.(?=.?$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.(?=.?$)', 'gm')
const str = `-1:23`;
const subst = `<span>$0</span>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);