$re = '/.(?=.?$)/m';
$str = '-1:23';
$subst = "<span>$0</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;