import re
regex = re.compile(r".(?=.?$)", flags=re.MULTILINE)
test_str = "-1:23"
subst = "<span>$0</span>"
result = regex.sub(subst, test_str)
if result:
print(result)