#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(-?\d+)((\s*(\p{Punct})\s*)-?\d+)(\2)*$"
Local $sString = "1 - 1 - 1" & @CRLF & _
"3 - 2 - 2" & @CRLF & _
"3 - 2 - 2 - 2" & @CRLF & _
"1 - 7 - 7 - 7" & @CRLF & _
"1 -5 -5 -5" & @CRLF & _
"1-2-2-2" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")