import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(-?\\d+)((\\s*(\\p{Punct})\\s*)-?\\d+)(\\2)*$";
final String string = "1 - 1 - 1\n"
+ "3 - 2 - 2\n"
+ "3 - 2 - 2 - 2\n"
+ "1 - 7 - 7 - 7\n"
+ "1 -5 -5 -5\n"
+ "1-2-2-2\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}