using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(-?\d+)((\s*(\p{Punct})\s*)-?\d+)(\2)*$";
string input = @"1 - 1 - 1
3 - 2 - 2
3 - 2 - 2 - 2
1 - 7 - 7 - 7
1 -5 -5 -5
1-2-2-2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}