$re = '/^(-?\d+)((\s*(\p{Punct})\s*)-?\d+)(\2)*$/m';
$str = '1 - 1 - 1
3 - 2 - 2
3 - 2 - 2 - 2
1 - 7 - 7 - 7
1 -5 -5 -5
1-2-2-2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);