const regex = new RegExp('^(-?\\d+)((\\s*(\\p{Punct})\\s*)-?\\d+)(\\2)*$', 'gm')
const str = `1 - 1 - 1
3 - 2 - 2
3 - 2 - 2 - 2
1 - 7 - 7 - 7
1 -5 -5 -5
1-2-2-2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}