using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"DB(1000|0[1-9]|[1-9]\d{0,2})\.DB[XBDW](1000|0[1-9]|[1-9]\d{0,2})\.(0|10|[1-9])";
string input = @"|""DB1.DBX1.0""|""DB1000.DBB1000.0""|""DB18.DBD4.0""|""DB99.DBW999.0""|
such that DB[1-1000].DB[X,B,D,W][1-1000.0-10]
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}