const regex = /DB(1000|0[1-9]|[1-9]\d{0,2})\.DB[XBDW](1000|0[1-9]|[1-9]\d{0,2})\.(0|10|[1-9])/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DB(1000|0[1-9]|[1-9]\\d{0,2})\\.DB[XBDW](1000|0[1-9]|[1-9]\\d{0,2})\\.(0|10|[1-9])', 'gms')
const str = `|"DB1.DBX1.0"|"DB1000.DBB1000.0"|"DB18.DBD4.0"|"DB99.DBW999.0"|
such that DB[1-1000].DB[X,B,D,W][1-1000.0-10]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}