// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?ms)DB(1000|0[1-9]|[1-9]\d{0,2})\.DB[XBDW](1000|0[1-9]|[1-9]\d{0,2})\.(0|10|[1-9])").unwrap();
let string = "|\"DB1.DBX1.0\"|\"DB1000.DBB1000.0\"|\"DB18.DBD4.0\"|\"DB99.DBW999.0\"|
such that DB[1-1000].DB[X,B,D,W][1-1000.0-10]
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}