re = /DB(1000|0[1-9]|[1-9]\d{0,2})\.DB[XBDW](1000|0[1-9]|[1-9]\d{0,2})\.(0|10|[1-9])/m
str = '|"DB1.DBX1.0"|"DB1000.DBB1000.0"|"DB18.DBD4.0"|"DB99.DBW999.0"|
such that DB[1-1000].DB[X,B,D,W][1-1000.0-10]
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end