const regex = new RegExp('^.*?Updated:', 's')
const str = `Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);