use strict;
my $str = 'Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019';
my $regex = qr/^.*?Updated:/sp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";