$re = '/^.*?Updated:/s';
$str = 'Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;