re = /^.*?Updated:/
str = 'Blah blah
blah, Updated: Aug. 23, 2012 Blah blah Updated: Feb. 13, 2019'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result