using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|[^\/]){([^}]*)}";
string input = @"{include} anything in {curly braces} but not when they are escaped like /{this} and work for any position of the {brace}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}