$re = '/(?:^|[^\/]){([^}]*)}/';
$str = '{include} anything in {curly braces} but not when they are escaped like /{this} and work for any position of the {brace}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);