package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:^|[^\/]){([^}]*)}`)
var str = `{include} anything in {curly braces} but not when they are escaped like /{this} and work for any position of the {brace}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}