// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:^|[^\/]){([^}]*)}").unwrap();
let string = "{include} anything in {curly braces} but not when they are escaped like /{this} and work for any position of the {brace}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}