re = /(?:^|[^\/]){([^}]*)}/
str = '{include} anything in {curly braces} but not when they are escaped like /{this} and work for any position of the {brace}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end