#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\([^\)]*(?=\.\w+$)"
Local $sString = "02 Back for Good (Radio Mix).mp3" & @CRLF & _
"02 Back for Good (Radio Mix.mp3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")