re = /\([^\)]*(?=\.\w+$)/m
str = '02 Back for Good (Radio Mix).mp3
02 Back for Good (Radio Mix.mp3'
# Print the match result
str.match(re) do |match|
puts match.to_s
end