const regex = /\([^\)]*(?=\.\w+$)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^\\)]*(?=\\.\\w+$)', 'm')
const str = `02 Back for Good (Radio Mix).mp3
02 Back for Good (Radio Mix.mp3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}