$re = '/\([^\)]*(?=\.\w+$)/m';
$str = '02 Back for Good (Radio Mix).mp3
02 Back for Good (Radio Mix.mp3';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);