#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+(?:(?: \d+)*\/\d+)?)$"
Local $sString = "1" & @CRLF & _
"200" & @CRLF & _
"1/2" & @CRLF & _
"3/8" & @CRLF & _
"1 1/2" & @CRLF & _
"200 3/8" & @CRLF & _
"" & @CRLF & _
"NOT" & @CRLF & _
"number" & @CRLF & _
"5%" & @CRLF & _
"1 1/2 4" & @CRLF & _
"1 1/2 1/2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")