$re = '/^(\d+(?:(?: \d+)*\/\d+)?)$/m';
$str = '1
200
1/2
3/8
1 1/2
200 3/8
NOT
number
5%
1 1/2 4
1 1/2 1/2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);