re = /^(\d+(?:(?: \d+)*\/\d+)?)$/m
str = '1
200
1/2
3/8
1 1/2
200 3/8
NOT
number
5%
1 1/2 4
1 1/2 1/2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end