import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d+(?:(?: \\d+)*\\/\\d+)?)$";
final String string = "1\n"
+ "200\n"
+ "1/2\n"
+ "3/8\n"
+ "1 1/2\n"
+ "200 3/8\n\n"
+ "NOT\n"
+ "number\n"
+ "5%\n"
+ "1 1/2 4\n"
+ "1 1/2 1/2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}