using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b ?([A-Za-z-]+) ?\b";
string input = @"""Right now!"" she shouted, and hands fluttered in the air - amid a few cheers - for about two minutes.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}