const regex = /\b ?([A-Za-z-]+) ?\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b ?([A-Za-z-]+) ?\\b', 'g')
const str = `"Right now!" she shouted, and hands fluttered in the air - amid a few cheers - for about two minutes.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}