$re = '/\b ?([A-Za-z-]+) ?\b/';
$str = '"Right now!" she shouted, and hands fluttered in the air - amid a few cheers - for about two minutes.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);