// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b ?([A-Za-z-]+) ?\b").unwrap();
let string = "\"Right now!\" she shouted, and hands fluttered in the air - amid a few cheers - for about two minutes.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}