#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(:.+)(?(1)Cool!)"
Local $sString = "# match String Cool! only if there is a : somewhere preciding it" & @CRLF & _
"Ein String: mit einem Zeichen drin Cool!" & @CRLF & _
"Ein String ohne Zeichen drin Cool!"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)