// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(:.+)(?(1)Cool!)").unwrap();
let string = "# match String Cool! only if there is a : somewhere preciding it
Ein String: mit einem Zeichen drin Cool!
Ein String ohne Zeichen drin Cool!";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}