re = /(:.+)(?(1)Cool!)/m
str = '# match String Cool! only if there is a : somewhere preciding it
Ein String: mit einem Zeichen drin Cool!
Ein String ohne Zeichen drin Cool!'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result