const regex = /(:.+)(?(1)Cool!)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:.+)(?(1)Cool!)', 'gm')
const str = `# match String Cool! only if there is a : somewhere preciding it
Ein String: mit einem Zeichen drin Cool!
Ein String ohne Zeichen drin Cool!`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);